• 當前位置: 網站首頁 > 股票軟件公式 > 飛狐公式 > 文章 當前位置: 飛狐公式 > 文章

    買賣單統計,統計買賣單的各項數據(飛狐公式)

    點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

    {半分位}
    STICKLINE(CLOSE>0,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,8,101),colorWhite,LINETHICK3;
    STICKLINE(LOW<>MIN(CLOSE,OPEN),(LOW+MIN(CLOSE,OPEN))/2,(LOW+MIN(CLOSE,OPEN))/2,4,1),COLORYELLOW,LINETHICK1;
    STICKLINE(HIGH<>MAX(CLOSE,OPEN),(HIGH+MAX(CLOSE,OPEN))/2,(HIGH+MAX(CLOSE,OPEN))/2,4,1),COLORYELLOW,LINETHICK1;
    {均線}
    wx:=MA(CLOSE,0);
    M5:MA(CLOSE,5),COLORYELLOW;
    M10:MA(CLOSE,10)*IF(n<2,wx,1),COLORMAGENTA;
    M20:MA(CLOSE,20)*IF(n<3,wx,1),COLORWHITE;
    {M30:=MA(CLOSE,30)*IF(n<4,wx,1);
    M60:=MA(CLOSE,60)*IF(n<4,wx,1);
    M90:=MA(CLOSE,90)*IF(n<4,wx,1);}
    {布林軌道}
    {市值定價}
    市盈率:=IF(FINANCE(33)>0,DYNAINFO(39),0)*0.35;
    每股收益:=IF(FINANCE(33)>0.01,FINANCE(33)*0.65,0);
    市值定價:=每股收益*市盈率*4;
    DRAWTEXTEX(CLOSE,1,485,10,'【市值定價】'+NUMTOSTR(市值定價,2)+' 元'),COLORYELLOW;
    {飽和量能}
    SAT:=IF((AMOUNT/CLOSE)/(HHV(AMOUNT,21)/HHV(CLOSE,21))*100>100,100,(AMOUNT/CLOSE)/(HHV(AMOUNT,21)/HHV(CLOSE,21))*100);
     
    p:=SYSPARAM(1);
    DRAWTEXTEX(CLOSE,1,485,70,'【飽和量能】'+NUMTOSTR(SAT,2)+' %'),COLORYELLOW;
     
    {主力籌碼}
    主力籌碼:=10*WINNER(CLOSE*0.9)*8;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,40,'【主力籌碼】'+NUMTOSTR(主力籌碼[SYSPARAM(1)],2)+' %'),COLORYELLOW,PXUP0;
    ZHH:=HIGH;ZGF1:= ZHH/1.0809;  ZGF2:=ZHH/1.1618;   ZGF3:=ZHH/1.0809/1.1618; ZGF4:=ZHH/1.1618/1.1618; 
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,70,'■第一下跌區位:'+NUMTOSTR(ZGF1[SYSPARAM(1)],2)+'-'+NUMTOSTR(ZGF2[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,100,'■第二下跌區位:'+NUMTOSTR(ZGF3[SYSPARAM(1)],2)+'-'+NUMTOSTR(ZGF4[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
    ZLL:=LOW;ZGFB1:=ZLL*1.0809;    ZGFB2:=ZLL*1.1618;   ZGFB3:=ZLL*1.0809*1.1618;  ZGFB4:=ZLL*1.1618*1.1618;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,40,'■第一上漲區位:'+NUMTOSTR(ZGFB1[SYSPARAM(1)],2)+''+'-'+NUMTOSTR(ZGFB2[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,10,'■第二上漲區位:'+NUMTOSTR(ZGFB3[SYSPARAM(1)],2)+''+'-'+NUMTOSTR(ZGFB4[SYSPARAM(1)],2)+' 元'),COLORYELLOW;
    PT:=REF(HIGH,1)-REF(LOW,1);
    CDP:=(HIGH+LOW+2*CLOSE)/4;
    AH:=CDP+PT;
    AL:=CDP-PT;
    NH敏感阻力:=2*CDP-LOW;
    NL:=2*CDP-HIGH;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,130,'■明日強阻力位:'+NUMTOSTR(AH[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,160,'■明日阻力區域:'+NUMTOSTR(NH敏感阻力[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,190,'■明日均衡價位:'+NUMTOSTR(CDP[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,220,'■明日支撐區域:'+NUMTOSTR(NL[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,250,'■明日強支撐位:'+NUMTOSTR(AL[SYSPARAM(1)],2)+' 元'),COLORYELLOW,PXUP0;
    主力持倉:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
    主力籌碼集中度:=WINNER(CLOSE)*100;
    散籌籌碼集中度:=(WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*100;
    qiang:=(主力持倉-散籌籌碼集中度)>20 and (主力籌碼集中度-散籌籌碼集中度)>0 and 主力持倉>50;
    莊家顯身:=IF(qiang,1,0);
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,460,'■莊家顯身:'+NUMTOSTR(莊家顯身[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
    莊家控局:=IF(qiang and 主力籌碼集中度-散籌籌碼集中度>20,1,0);
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,490,'■莊家控局:'+NUMTOSTR(莊家控局[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
    A2:=SUM(VOL,13)/CAPITAL;
    強弱分界:=100-(100/(1+A2));
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,400,'■弱勢指數:'+NUMTOSTR(強弱分界[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
    A3:=LLV(DMA(CLOSE,VOL/CAPITAL),120);
    股價走勢:=100*(CLOSE-A3)/A3;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,430,'■強勢指數:'+NUMTOSTR(股價走勢[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
    {D J 系數}
    RSV:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
    K:=SMA(RSV,P1,1);
    D:=SMA(K,P2,1);
    起漲系數:=3*K-2*D;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,485,130,'【D J 系數】↓'+NUMTOSTR(起漲系數[SYSPARAM(1)],2)+' %'),COLORYELLOW,PXUP0;
    {資金進出}
    V1:=(CLOSE*2+HIGH+LOW)/4*10; 
    V2:=EMA(V1,13)-EMA(V1,34); 
    V3:=EMA(V2,5); V4:=2*(V2-V3)*5.5; 
    主力進:=IF(V4>=0,V4,0);  
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,340,'■主力進場強度:'+NUMTOSTR(主力進[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
    主力撤:=IF(V4<=0,V4,0);
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,370,'■主力出場強度:'+NUMTOSTR(主力撤[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
    V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8; 
    V6:=EMA(3*V5-2*SMA(V5,18,1),5); 
    V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10; 
    V8:=(INDEXC*2+INDEXH+INDEXL)/4; 
    V9:=EMA(V8,13)-EMA(V8,34); 
    VA:=EMA(V9,3); 
    VB:=(V9-VA)/2; 
    {股民學院 www.karatetvonline.com 整理}
    資金進場:=IF(VB>=0,VB,0);
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,280,'■資金進場強度:'+NUMTOSTR(資金進場[SYSPARAM(1)],2)),COLORYELLOW,PXUP0; 
    資金出場:=IF(VB<=0,VB,0); 
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,310,'■資金出場強度:'+NUMTOSTR(資金出場[SYSPARAM(1)],2)),COLORYELLOW,PXUP0;
    {建倉}
    Q4:=34;
    Q5:=9;
    Q6:=3;
    X1:=100*(HHV(HIGH,Q4)-CLOSE)/(HHV(HIGH,Q4)-LLV(LOW,Q4));
    VAR1:=100*(HHV(HIGH,Q5)-CLOSE)/(HHV(HIGH,Q5)-LLV(LOW,Q5));
    VAR2:=100*(HHV(HIGH,Q6)-CLOSE)/(HHV(HIGH,Q6)-LLV(LOW,Q6));
    VAR3:=VAR1-X1;
    VAR4:=X1-VAR1;
    游資建倉:=VAR3<0;
    機構對倒:=VAR4<0;
    VAR5:=DYNAINFO(5);
    VAR6:=IF(HIGH<VAR5,0,IF(LOW>VAR5,1,(VAR5-HIGH+0.009)/(LOW-HIGH+0.009)));
    AAA:=CLOSE*1.1;
    BBB:=CLOSE*0.9;
    BB1:=100*(WINNER(AAA)-WINNER(BBB));
    CMSD:=100-BB1;
    CC1:=MA(CLOSE,13)<REF(MA(CLOSE,13),1);
    DD1:=IF(CLOSE>1000,CROSS(VAR6,22),CROSS(VAR6,24));
    機構建倉:=CMSD>65 AND CC1;
    ZC_1:=IF(LOW<DYNAINFO(7),0,IF(HIGH>DYNAINFO(7),DYNAINFO(7)-(DYNAINFO(7)-HIGH+0.02)/(HIGH-LOW+0.02),0));
    ZC_2:=DMA(ZC_1,VOL/CAPITAL)*(100);
    出貨:=IF(ZC_2>0 AND ZC_2>REF(ZC_2,1),ZC_2/20,0);
    機構出貨:=出貨>0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,520,'■機構參與:'+NUMTOSTR(機構建倉[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,610,'■機構出貨:'+NUMTOSTR(機構出貨[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,580,'■機構對倒:'+NUMTOSTR(機構對倒[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
    DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,20,550,'■游資參與:'+NUMTOSTR(游資建倉[SYSPARAM(1)],0)),COLORYELLOW,PXUP0;
    {權證}
    Var1:=IF(DATE<1090801 AND DATE>900101,1,0);
    VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
    VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
    VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND

    上一篇:自用布林線(飛狐公式)

    下一篇:沒有了

    推薦閱讀
    一级毛片试看三分钟,俄罗斯高清免费一级毛片,欧美牲交A欧美牲交AⅤ一