• 當前位置: 網站首頁 > 股票軟件公式 > 同花順公式 > 文章 當前位置: 同花順公式 > 文章

    金蜘蛛改良(同花順公式)

    點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

     金蜘蛛改良,通達信版本獲得很多的稱贊,現在同花順版本來了

    //金蜘蛛改良
    X_0:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
    X_1:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
    X_2:=SMA(X_0,3,1);
    X_3:=SMA(X_2,3,1);
    X_4:=EMA(SMA(X_1,3,1),2);
    X_5:=SMA(X_4,3,1);
    DRAWTEXT(CROSS(X_2,X_3) AND CROSS(X_4,X_5),9,' 共振點'),coloryellow;
    DRAWICON(CROSS(X_2,X_3) AND CROSS(X_4,X_5),9,23);
    X_6:=EMA(CLOSE,12) - EMA(CLOSE,26);
    X_7:=EMA(X_6,9);
    X_8:=2*(X_6-X_7);
    X_9:=IF(CROSS(0,X_7),1,0);
    X_10:=IF(X_6<0 AND CROSS(X_6,X_7),1,0);
    X_11:=IF(X_9,SUM(X_10,0),0);
    X_12:=HHV(X_11,0);
    X_13:=SUM(X_10,0);
    X_14:=39;X_15:=1;
    X_16:=REF(LLV(L,X_14),X_15);
    X_17:=REFDATE(X_16,DATE);
    W底選股:IF(X_13-X_12=2 AND X_13>REF(X_13,1),-22,0),LINETHICK2,COLORFFFF00;
    IF(X_13-X_12=2 AND X_13>REF(X_13,1),-12,0),LINETHICK2,COLORFFFF00;
    DRAWTEXT(X_10,-8,'↖W底'),coloryellow;
    DRAWTEXT_FIX(1,0.50,5,0,'~☆~金蜘蛛改良版~☆~'),colorred;
    X_18:=LLV(LOW,27);
    X_19:=HHV(HIGH,34);
    X_20:=EMA((CLOSE-X_18)/(X_19-X_18)*4,4)*25;
    建倉區: IF((X_20<10),-6,0) ,coloryellow,LINETHICK3;
    IF((X_20<10),-3,0) ,colorblack,LINETHICK3;
    X_21:=REF(LLV(L,20),3);
    X_22:=REFDATE(X_21,DATE);
    X_23:=EMA(C,2);X_24:=EMA(C,5);X_25:=EMA(C,13);X_26:=EMA(C,30);
    X_27:=X_24>=REF(X_24,1);
    X_28:=MAX(MAX(X_24,X_25),X_26);X_29:=MIN(MIN(X_24,X_25),X_26);
    X_30:= X_28<C AND O<X_29 AND X_27 AND X_23>REF(X_23,1);
    滿倉選股:IF(X_30,38,0),colormagenta,LINETHICK3;
    IF(X_30,30,0),colorblack,LINETHICK3;
    DRAWTEXT(X_30,42,'↙滿'),coloryellow;
    X_31:=0.0001*AMOUNT;
    X_32:=0.0001*MA(AMOUNT,5);
    X_33:=0.0001*MA(AMOUNT,10);
    百日地量:LLV(X_31,100)=X_31,STICK,COLORCC66FF;
    DRAWTEXT(百日地量,-8,'↖地'),COLORCC66FF;
    X_34:=MA(C,5);
    X_35:=(C-X_34)/X_34*100;
    X_36:=ATAN((X_34/REF(X_34,1)-1)*100)*180/3.1416;
    X_37:=SMA(EMA((X_34-REF(X_34,1))/REF(X_34,1),3)*100,3,1);
    X_38:=EMA((X_37-REF(X_37,1)),3);
    X_39:=MA(C,10);
    X_40:=ATAN((X_39/REF(X_39,1)-1)*100)*180/3.1416;
    X_41:=MA(C,30);X_42:=MA(C,20);
    X_43:=(C-X_41)/X_41*100;
    (X_42-X_41)>REF((X_42-X_41),1) AND X_42>REF(X_42,1) AND X_41>REF(X_41,1);
    (X_41-X_42)<REF((X_41-X_42),1) AND X_42<REF(X_42,1) AND X_41<REF(X_41,1);
    X_44:=ATAN((X_41/REF(X_41,1)-1)*100)*180/3.1416;
    強勢選股:FILTER(X_44>30 AND X_40>45 AND CROSS(X_36,60),10);
    加倉:FILTER(COUNT(CROSS(X_36,30),5)>=1 AND X_34>REF(X_34,1) AND X_43>REF(X_43,1) AND X_39>REF(X_39,1) AND X_38>REF(X_38,1) AND X_37>REF(X_37,1) ,10) ;
    X_45:=COUNT(CROSS(X_35,0),3)>=1 AND X_43>REF(X_43,1) AND X_34>REF(X_34,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<X_41;
    青云直上選股:IF(FILTER(X_45,10),30,0),colorred,LINETHICK3;
    IF(FILTER(X_45,10),20,0),colorblack,LINETHICK3;
    DRAWTEXT(FILTER(X_45,10),35,'↙青'),colorred;
    X_46:=REF(CLOSE,1);
    RSI:=SMA(MAX(CLOSE-X_46,0),6,1)/SMA(ABS(CLOSE-X_46),6,1)*100;
    逃頂:CROSS(80,RSI)*50,LINETHICK3 ,colorgreen;
    CROSS(80,RSI)*40,LINETHICK3 ,colorblack;
    DRAWTEXT(CROSS(80,RSI),52,' ↙頂 '),colorgreen;
    X_47:=(2*CLOSE+HIGH+LOW)/4;
    X_48:=LLV(LOW,34);
    X_49:=HHV(HIGH,34);
    Y:EMA((X_47-X_48)/(X_49-X_48)*100,13),colorred;
    D:EMA(0.667*REF(Y,1)+0.333*Y,2),coloryellow;
    STICKLINE(D<Y,Y,D,2,0),colorred;
    DRAWICON(CROSS(Y,D),Y,23);
    X_50:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
    X_51:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
    X_52:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
    X_53:=(X_50+2*X_51+3*X_52)/6;
    X_54:=MA(X_53,3);
    x_55:=LLV(LOW,36);
    X_56:=HHV(HIGH,30);
    X_57:=EMA((CLOSE-x_55)/(X_56-x_55)*4,4)*25;
    底背離:IF(X_54<-4 ,-11,0),COLORA67D3D,LINETHICK3;
    頂背離:IF((X_57>90),110,100), colorgreen,LINETHICK3;
    IF(X_54<-4 ,-8,0),colorblack,LINETHICK2;
    IF((X_57>90),106,100), colorblack,LINETHICK3;
    100,COLORFFFF00, LINETHICK1;
    DRAWICON(加倉=1,Y*1.01,9);
    DRAWTEXT(加倉=1,Y*1.05,' 加倉'),colorred;

    上一篇:分批買入ABC(同花順公式)

    下一篇:等你來買(同花順公式)

    一级毛片试看三分钟,俄罗斯高清免费一级毛片,欧美牲交A欧美牲交AⅤ一