• 當前位置: 網站首頁 > 股票軟件公式 > 同花順公式 > 文章 當前位置: 同花順公式 > 文章

    預報CCI(同花順公式)

    點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

     //預報CCI

    N:=14;M:=56;
    紅多藍空:STKNAME,colorwhite;
    TYP:=(HIGH+LOW+CLOSE)/3;
    CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N)),colormagenta,LINETHICK1;
    CCI1:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),coloryellow,LINETHICK1;
    升:IF(CCI>REF(CCI,1),CCI,DRAWNULL),COLORFF00FF,LINETHICK2;
    降:IF(CCI<REF(CCI,1),CCI,DRAWNULL),COLOR00FF00,LINETHICK1;
    爆發線:100,DOTLINE,colorFF00FF;
    吸籌線:-100,DOTLINE,colorliblue;
    F1:=ZIG(3,15);
    方向:=IF((F1> REF(F1,1)),-100,100);
    STICKLINE(方向>90,-100,-150,10,0),COLORFF9428;
    STICKLINE(方向<0,-100,-150,10,0),colorFF00FF;
    STICKLINE(方向>90,100,150,10,0),COLORFF9428;
    STICKLINE(方向<0,100,150,10,0),colorFF00FF;
    FILLRGN(CCI,100,CCI>100,RGB(50,225,50),CCI<-100,RGB(250,150,50));
    STICKLINE(C>1,100,-100,20,0),colorblack;
    必買: IF(TROUGHBARS(3,5,1)=0 AND HIGH>LOW+0.01,70,0),colormagenta ,linethick3,STICK ;
    必賣: IF(PEAKBARS(3,5,1)=1,70,0),colorgreen,linethick3,STICK;
    總億:AMOUNT/100000000,COLORFF00FF,NODRAW;
    VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
    流入億:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/100000000,colorred,NODRAW;
    流出億:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-AMOUNT/2))/100000000,COLOR00FF00,NODRAW;
    差額億:流入億+流出億,COLORFFFF00,NODRAW;
    中軸線:0, colorwhite,LINETHICK1;
    地域:DRAWTEXT_FIX(ISLASTBAR,0.20,0,1,BLOCK(2,1)),coloryellow;
    所屬行業:DRAWTEXT_FIX(ISLASTBAR,0.36,0,1,BLOCK(1,1)),coloryellow;
    主概念:DRAWTEXT_FIX(ISLASTBAR,0.1,0,1,BLOCK(3,1)),colorred;
    N:=40;
    N1:=20;
    VAR1:=((3 * SMA((((CLOSE - LLV(LOW,N)) / (HHV(HIGH,N) - LLV(LOW,N))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,N)) / (HHV(HIGH,N) - LLV(LOW,N))) * 100),5,1),3,1)));
    VAR2:=((3 * SMA((((CLOSE - LLV(LOW,N1)) / (HHV(HIGH,N1) - LLV(LOW,N1))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,N1)) / (HHV(HIGH,N1) - LLV(LOW,N1))) * 100),5,1),3,1)));
    股價啟動在即:=IF(CROSS(VAR2,VAR1),100,0);
    秘密買點:IF((VAR2 <= 3),55,0),colorwhite;
    機構建增補倉:=IF((VAR2 < 5),45,0);
    絕密買點:IF((VAR2 <= 0),55,0),colorred;
    STICKLINE(VAR2<0 ,0,50,0.5,0),colorred;
    抄底: IF(TROUGHBARS(2,5,1)=0 AND HIGH>LOW+0.01,2,0),coloryellow ,LINETHICK2 ;
    VAR3:=PEAKBARS(3,15,1)<10;
    VAR5:=IF(VAR3=1,2,0);
    頂:= IF(VAR5=2,2,0),COLOR00FF00,LINETHICK3,STICK;
    頂A:IF(頂>REF(頂,1),2,0),colorgreen,LINETHICK3,STICK;
    DRAWTEXT(頂A=50,6,'逃頂'),COLOR00FF00,LINETHICK3,STICK;
    DRAWTEXT(抄底=20,30,'抄底'),coloryellow,LINETHICK3,STICK;
    LC:=REF(CLOSE,1);
    rsi1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLOR555555;
    大買主升浪:IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,90,0),COLOR1010FF,LINETHICK2;
    V6:=CLOSE/REF(CLOSE,3)>=1.1;
    V7:=BACKSET(V6,4);
    漲停初現:IF((V7 AND COUNT(V7,3)=1),40,0),colorcyan,STICK,LINETHICK3;
    LS:=C/REF(C,1)>1.040 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1
    *FORCAST(V,5)),COLORFF6600,LINETHICK1;
    買漲停:FILTER(LS,28)*40,COLORFF6600,LINETHICK3 ,STICK;

    上一篇:刀哥多空博弈(同花順公式)

    下一篇:沒有了

    一级毛片试看三分钟,俄罗斯高清免费一级毛片,欧美牲交A欧美牲交AⅤ一