• 當前位置: 網站首頁 > 股票軟件公式 > 通達信公式 > 文章 當前位置: 通達信公式 > 文章

    價托黃金柱,是價托+黃金柱+一陽穿三的組合公式( 通達信公式 )

    點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

    本指標價托黃金柱,是價托+黃金柱+一陽穿三三個指標的的組合
    開源分享。

    DRAWBAND(MA(CLOSE,60),RGB(80,0,0),MA(CLOSE,120),RGB(0,91,0));
    DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
    DRAWKLINE(H,O,L,C);
    MA5:=MA(CLOSE,5),COLORWHITE;
    MA10:=MA(CLOSE,10),COLORYELLOW;
    MA30:=MA(CLOSE,30),COLORMAGENTA;
    MA60:=MA(CLOSE,60),COLORGREEN;
    MA120:=MA(CLOSE,120),COLORLIMAGENTA;
    MA240:=MA(CLOSE,240),COLORBLUE,NODRAW; 
    VOL5:=MA(VOL,5),COLORWHITE;
    VOL10:=MA(VOL,10),COLORYELLOW;
    VOL40:=MA(VOL,40),COLORFF00FF ;
    量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1);
    DRAWTEXT(量托,L-0.012,'量托'),COLORWHITE;
    AA1:=BARSLAST(MA60>MA30 AND (MA30=MA10 OR MA30>MA10));
    BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
    CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
    芙蓉出水:=BB1 AND CC1,COLOR00FF00;
    DRAWTEXT(芙蓉出水,H+0.3,'芙蓉出水'),COLORFF00FF;
    STICKLINE(芙蓉出水,H,L,1,1),COLORFF00FF;
    STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;
    MA1:=MA(CLOSE,5);
    MA2:=MA(CLOSE,10);
    MA3:=MA(CLOSE,20);
    ZJ:=AMOUNT/10000;{資金}
    TM:=V-MA(V,10);{量填滿}
    一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
    DRAWTEXT(一穿三,L-0.012,'一穿三'),COLORFF00FF;
    STICKLINE(一穿三,OPEN,CLOSE,1,0),COLORFF00FF;
    TY:=C;
    A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
    A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
    前期高位:REF(C,BARSLAST(HD)),COLORBLUE,POINTDOT;
    STICKLINE(C,前期高位,前期高位,8,0),COLORBLUE; 
    {高點:=(C/REF(C,BARSLAST(HD))-1)*100,NODRAW;
    STICKLINE((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667,H,C,0.8,0),COLORBLUE;}
    三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
    三日量縮:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
    三日價漲A:=C>=REF(C,1);
    三日價漲B:=C<REF(C,1);
    三日價漲C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
    TIM:=IF(DATE<1140214,1,0);
    縮倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
    百日低量:=(VOL=LLV(VOL,100))*TIM;
    倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
    四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
    四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量縮)*TIM;
    前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日價漲C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日價漲C,1)),3)=0;
    倍量黃金柱:=四日前倍量柱 AND 三日量縮 AND 三日不破 AND 三日價漲A AND 前三引用不成立;
    高量黃金柱:=四日前高量柱 AND 三日量縮 AND 三日不破 AND 三日價漲A AND 前三引用不成立;
    黃金柱:=倍量黃金柱 OR 高量黃金柱;
    次倍量黃金柱:=NOT(黃金柱) AND 四日前倍量柱 AND 三日量縮 AND 三日不破 AND 三日價漲B AND 前三引用不成立;
    次高量黃金柱:=NOT(黃金柱) AND 四日前高量柱 AND 三日量縮 AND 三日不破 AND 三日價漲B AND 前三引用不成立;
    次黃金柱:=次倍量黃金柱 OR 次高量黃金柱;
    準倍量黃金柱:=NOT(黃金柱 OR 次黃金柱) AND 四日前倍量柱 AND ((三日量縮 AND 三日價漲C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
    準高量黃金柱:=NOT(黃金柱 OR 次黃金柱) AND 四日前高量柱 AND (三日量縮 AND 三日價漲C) AND 前三引用不成立;
    準黃金柱:=準倍量黃金柱 OR 準高量黃金柱;
    倍量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱) AND 四日前倍量柱 AND 三日不破 AND 三日價漲A AND 前三引用不成立;
    高量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱) AND 四日前高量柱 AND 三日不破 AND 三日價漲A AND 前三引用不成立;
    將軍柱:=倍量將軍柱 OR 高量將軍柱;
    次倍量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱) AND 四日前倍量柱 AND 三日不破 AND 三日價漲B AND 前三引用不成立;
    次高量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱) AND 四日前高量柱 AND 三日不破 AND 三日價漲B AND 前三引用不成立;
    次將軍柱:=次倍量將軍柱 OR 次高量將軍柱;
    準倍量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱 OR 次將軍柱) AND 四日前倍量柱 AND 三日價漲C AND 前三引用不成立;
    準高量將軍柱:=NOT(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱 OR 次將軍柱) AND 四日前高量柱 AND 三日價漲C AND 前三引用不成立;
    準將軍柱:=準倍量將軍柱 OR 準高量將軍柱;
    BACKSET100:=BACKSET(黃金柱 OR 次黃金柱 OR 準黃金柱 OR 將軍柱 OR 次將軍柱 OR 準將軍柱,4);
    FILTER100:=FILTER(BACKSET100,3),NODRAW;
    BACKSET101:=BACKSET(黃金柱,4);
    FILTER101:=FILTER(BACKSET101,3);
    BACKSET102:=BACKSET(次黃金柱,4);
    FILTER102:=FILTER(BACKSET102,3);
    BACKSET103:=BACKSET(準黃金柱,4);
    FILTER103:=FILTER(BACKSET103,3);
    BACKSET104:=BACKSET(將軍柱,4);
    FILTER104:=FILTER(BACKSET104,3);
    BACKSET105:=BACKSET(次將軍柱,4);
    FILTER105:=FILTER(BACKSET105,3);
    BACKSET106:=BACKSET(準將軍柱,4);
    FILTER106:=FILTER(BACKSET106,3);
    黃金線下影線:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);
    黃金線實體下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;
    黃金線上影線:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);
    黃金線實體上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);
    黃金線實體中間:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));
    黃金線實體中間1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));
    黃金線實體中間2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));
    黃金線實體中間3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));
    BACKSET201:=BACKSET(黃金線下影線,4);
    FILTER201:=FILTER(BACKSET201,3),NODRAW;
    BACKSET202:=BACKSET(黃金線實體下端,4);
    FILTER202:=FILTER(BACKSET202,3),NODRAW;
    BACKSET203:=BACKSET(黃金線上影線,4);
    FILTER203:=FILTER(BACKSET203,3),NODRAW;
    BACKSET204:=BACKSET(黃金線實體上端,4);
    FILTER204:=FILTER(BACKSET204,3),NODRAW;
    BACKSET205:=BACKSET(黃金線實體中間,4);
    FILTER205:=FILTER(BACKSET205,3),NODRAW;
    BACKSET2051:=BACKSET(黃金線實體中間1,4);
    FILTER2051:=FILTER(BACKSET2051,3),NODRAW;
    BACKSET2052:=BACKSET(黃金線實體中間2,4);
    FILTER2052:=FILTER(BACKSET2052,3),NODRAW;
    BACKSET2053:=BACKSET(黃金線實體中間3,4);
    FILTER2053:=FILTER(BACKSET2053,3),NODRAW;
    BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));
    BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));
    BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));
    BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));
    BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));
    BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));
    BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));
    BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));
    最近黃金線:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);
    DAY1:=SUMBARS(FILTER100,1),NODRAW;
    HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;
    HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
    HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;
    HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
    HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;
    HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;
    HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;
    黃金線:=HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;
    立樁量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
    立樁量三日突破:=IF(BARSLAST(立樁量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立樁量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立樁量)=3 AND CLOSE>REF(HIGH,3),1,0)));
    立樁量三日不破:=BARSLAST(立樁量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
    BACKSET300:=BACKSET(立樁量三日不破,4);
    BACKSET301:=BACKSET(立樁量三日突破,4);
    立樁量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立樁量;
    DRAWTEXT(立樁量成立,HIGH*1.01,'↙立樁量'),COLOR00FF00;
    DRAWTEXT(FILTER101,LOW*0.986,'↖黃金柱'),COLORYELLOW;
    STICKLINE(FILTER101,OPEN,CLOSE,0.5,0),COLORYELLOW;
    DRAWTEXT(FILTER102,LOW*0.986,'↖次黃金柱'),COLORYELLOW;
    DRAWTEXT(FILTER104,LOW*0.986,'↖將軍柱'),COLORYELLOW;
    STICKLINE(FILTER104,OPEN,CLOSE,1.5,0),COLORYELLOW;
    K1:=SUMBARS(FILTER104,1);
    STICKLINE(K1,REF(L,K1-2),REF(L,K1-2),10,0),COLORYELLOW; 
    K2:=SUMBARS(FILTER101,1);
    STICKLINE(K2,REF(L,K2-2),REF(L,K2-2),10,0),COLORYELLOW; 
    強勢5:MA(C,5),LINETHICK1;
    生命24:MA(C,24),COLORRED,LINETHICK1;
     
    DG1:=(CROSS(強勢5,生命24));
    DRAWICON(DG1,生命24,1);
     
    X1:=(C+L+H)/3;
    BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
    EMA3:=EMA(C,3);
    DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10),
    LOW*0.99,'★∠45'),COLORFFFFFF;
    漲家數:INDEXADV,NODRAW,COLORLIMAGENTA ;
    跌家數:INDEXDEC,NODRAW,COLORGREEN;
    C3:=REF(C,1);
    漲停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
    STICKLINE(漲停,OPEN,CLOSE,2.5,0),COLORRED;
    跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
    STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;

    上一篇:牛股起爆點A,抓牛股起爆前期的絕佳利器 結合火焰山指標(通達信公式)

    下一篇:后羿潛伏抄底(通達信公式)

    一级毛片试看三分钟,俄罗斯高清免费一级毛片,欧美牲交A欧美牲交AⅤ一